Product Search

    SEARCH NOW FOR ALL YOUR NOVOTECHNIK SOLUTIONS

    Radwell is here to supply you with all your plant floor needs.

    Radwell is not an authorised distributor, reseller or representative of the products featured on this website. All product names, trademarks, brands and logos used on this site are the property of their respective owners. The depiction, description or sale of products featuring these names, trademarks, brands and logos is for identification purposes only and is not intended to indicate any affiliation with or authorisation by any rights holder.

    Filter Results
    Results 201-250 of 590.
    NOVOTECHNIK GP03P6501A50

    NOVOTECHNIK

    GP03P6501A50

    POTENTIOMETER
    €344.83 Price with VAT: €410.35 Buy Surplus As Low As €228.41 Price with VAT: €271.80
    €228.41 Price with VAT: €271.80
    NOVOTECHNIK P6501A202

    NOVOTECHNIK

    P6501A202

    008202, ROTARY SHAFT-TYPE POTENTIOMETERS,
    €401.86 Price with VAT: €478.21 Buy Surplus As Low As €227.10 Price with VAT: €270.25
    €227.10 Price with VAT: €270.25
    NOVOTECHNIK 023262

    NOVOTECHNIK

    023262

    DISCONTINUED BY MANUFACTURER, POSITION TRANSDUCER
    Buy Surplus As Low As €94.21 Price with VAT: €112.11
    €94.21 Price with VAT: €112.11
    NOVOTECHNIK RFC-4801-609-322-256

    NOVOTECHNIK

    RFC-4801-609-322-256

    RFC-4801-609-322-256
    €151.09 Price with VAT: €179.79 Buy Surplus As Low As €90.65 Price with VAT: €107.88
    €90.65 Price with VAT: €107.88
    NOVOTECHNIK Z-RFC-P08

    NOVOTECHNIK

    Z-RFC-P08

    POSITION MARKER, FOR FRONTAL FIXATION, WITH 2 SCREWS, OR WITH THREADED PIN M5
    €35.91 Price with VAT: €42.73 Buy Surplus As Low As €22.44 Price with VAT: €26.70
    €22.44 Price with VAT: €26.70
    NOVOTECHNIK RFC4851-636-122-501

    NOVOTECHNIK

    RFC4851-636-122-501

    ROTARY POTENTIOMETER
    €258.62 Price with VAT: €307.76 Buy Surplus As Low As €129.76 Price with VAT: €154.41
    €129.76 Price with VAT: €154.41
    NOVOTECHNIK Z-TLM-P05

    NOVOTECHNIK

    Z-TLM-P05

    DISCONTINUED BY MANUFACTURER, GUIDED POSITION MARKER
    Buy Surplus As Low As €170.64 Price with VAT: €203.06
    €170.64 Price with VAT: €203.06
    NOVOTECHNIK RSC2802-212-411-432

    NOVOTECHNIK

    RSC2802-212-411-432

    SENSOR, HALL EFFECT, ROTARY DISPLACEMENT
    €407.92 Price with VAT: €485.42 Buy Surplus As Low As €203.96 Price with VAT: €242.71
    €203.96 Price with VAT: €242.71
    NOVOTECHNIK TS-0025

    NOVOTECHNIK

    TS-0025

    023232, LINEAR POTENTIOMETERS WITH OR WITHOUT RETURN SPRINGS, M16 CONNECTOR
    €555.77 Price with VAT: €661.37 Buy Surplus As Low As €248.90 Price with VAT: €296.19
    €248.90 Price with VAT: €296.19
    NOVOTECHNIK TLH-0500

    NOVOTECHNIK

    TLH-0500

    025320, LINEAR SLIDE-TYPE POTENTIOMETER,
    €1,232.37 Price with VAT: €1,466.52 Buy Surplus As Low As €549.88 Price with VAT: €654.36
    €549.88 Price with VAT: €654.36
    NOVOTECHNIK RSC2801-212-411-432

    NOVOTECHNIK

    RSC2801-212-411-432

    HALL EFFECT ROTARY DISPLACEMENT SENSOR
    €216.72 Price with VAT: €257.89 Buy Surplus As Low As €108.36 Price with VAT: €128.95
    €108.36 Price with VAT: €128.95
    NOVOTECHNIK MUW200-4

    NOVOTECHNIK

    MUW200-4

    054103, SIGNAL CONDITIONERS FOR USE WITH POTENTIOMETERS, OUTPUT = 4..20MA
    €400.03 Price with VAT: €476.04 Buy Surplus As Low As €219.92 Price with VAT: €261.70
    €219.92 Price with VAT: €261.70
    NOVOTECHNIK LWH-0550

    NOVOTECHNIK

    LWH-0550

    024522, LINEAR ROD-TYPE POTENTIOMETER WITH CLAMP MOUNTING,
    €1,047.82 Price with VAT: €1,246.91 Buy Surplus As Low As €629.23 Price with VAT: €748.78
    €629.23 Price with VAT: €748.78
    NOVOTECHNIK Z-TP1-P08

    NOVOTECHNIK

    Z-TP1-P08

    SLIDER POSITION MAGNET, GUIDED POSITION INDICATOR FOR TP1, ITEM # 005695
    €50.66 Price with VAT: €60.28 Buy Surplus As Low As €31.11 Price with VAT: €37.02
    €31.11 Price with VAT: €37.02
    NOVOTECHNIK Z-RFC-P02

    NOVOTECHNIK

    Z-RFC-P02

    ROTARY SENSOR, RFC SERIES, CONTACTLESS, POSITION MARKER
    €87.08 Price with VAT: €103.62 Buy Surplus As Low As €52.95 Price with VAT: €63.01
    €52.95 Price with VAT: €63.01
    NOVOTECHNIK LWH-175

    NOVOTECHNIK

    LWH-175

    POSITION TRANSDUCER, 175 RANGE, STAINLESS STEEL, EXTERNAL THREAD, M6
    €840.08 Price with VAT: €999.70 Buy Surplus As Low As €558.65 Price with VAT: €664.79
    €558.65 Price with VAT: €664.79
    NOVOTECHNIK P-2501-A502

    NOVOTECHNIK

    P-2501-A502

    003203, POTENTIOMETER, ROTARY SHAFT
    €284.66 Price with VAT: €338.75 Buy Surplus As Low As €113.14 Price with VAT: €134.64
    €113.14 Price with VAT: €134.64
    NOVOTECHNIK P-6501-4007

    NOVOTECHNIK

    P-6501-4007

    008218, ROTARY SHAFT-TYPE POTENTIOMETERS,
    €862.96 Price with VAT: €1,026.93 Buy Surplus As Low As €518.13 Price with VAT: €616.58
    €518.13 Price with VAT: €616.58
    NOVOTECHNIK LWG0360

    NOVOTECHNIK

    LWG0360

    026114, M12 CONNECTOR MODELS:, LINEAR ROD-TYPE POTENTIOMETER WITH PIVOT BEARING MOUNT
    €953.85 Price with VAT: €1,135.08 Buy Surplus As Low As €537.68 Price with VAT: €639.84
    €537.68 Price with VAT: €639.84
    NOVOTECHNIK RFC 4853 603 111 201

    NOVOTECHNIK

    RFC 4853 603 111 201

    ROTARY SENSOR, TOUCHLESS, 2-PART, MECHANICALLY DECOUPLED, IP67, IP6K9K
    €186.64 Price with VAT: €222.10 Buy Surplus As Low As €111.98 Price with VAT: €133.26
    €111.98 Price with VAT: €133.26
    NOVOTECHNIK TRS 75 A 502

    NOVOTECHNIK

    TRS 75 A 502

    POSITION TRANSDUCER, 55MM STROKE, 90 DEGREE CONNECTOR, EEM 33-72
    €429.26 Price with VAT: €510.82 Buy Surplus As Low As €257.73 Price with VAT: €306.70
    €257.73 Price with VAT: €306.70
    NOVOTECHNIK TRS-0075

    NOVOTECHNIK

    TRS-0075

    023273, LINEAR POTENTIOMETERS WITH OR WITHOUT RETURN SPRINGS, M16 CONNECTOR
    €652.51 Price with VAT: €776.49 Buy Surplus As Low As €291.21 Price with VAT: €346.54
    €291.21 Price with VAT: €346.54
    NOVOTECHNIK MAP-4010-001-101

    NOVOTECHNIK

    MAP-4010-001-101

    MEASURING DEVICE, MULTIFUNCTIONAL, WITH DISPLAY, MAP4000 SERIES
    €535.91 Price with VAT: €637.73 Buy Surplus As Low As €321.72 Price with VAT: €382.85
    €321.72 Price with VAT: €382.85
    NOVOTECHNIK IP6515-A502

    NOVOTECHNIK

    IP6515-A502

    ROTARY TRANSDUCER
    €427.63 Price with VAT: €508.88 Buy Surplus As Low As €56.59 Price with VAT: €67.34
    €56.59 Price with VAT: €67.34
    NOVOTECHNIK LWH-0250

    NOVOTECHNIK

    LWH-0250

    024510, LINEAR ROD-TYPE POTENTIOMETER WITH CLAMP MOUNTING,
    €353.01 Price with VAT: €420.09 Buy Surplus As Low As €211.81 Price with VAT: €252.05
    €211.81 Price with VAT: €252.05
    NOVOTECHNIK 105083

    NOVOTECHNIK

    105083

    CANNON CONNECTOR, RIGHT ANGLE CANNON CONNECTOR, AWS / IGP / IPS
    €75.54 Price with VAT: €89.90 Buy Surplus As Low As €45.33 Price with VAT: €53.94
    €45.33 Price with VAT: €53.94
    NOVOTECHNIK 602077

    NOVOTECHNIK

    602077

    COUPLING T-SERIES, FLEX SHAFT COUPLING FOR T/TS SERIES (Z-301-T5/M4),
    €79.99 Price with VAT: €95.18 Buy Surplus As Low As €47.99 Price with VAT: €57.11
    €47.99 Price with VAT: €57.11
    1 2 3 4 5 6 7 8 9 10 11