Product Search

    SEARCH NOW FOR ALL YOUR NOVOTECHNIK SOLUTIONS

    Radwell is here to supply you with all your plant floor needs.

    Radwell is not an authorised distributor, reseller or representative of the products featured on this website. All product names, trademarks, brands and logos used on this site are the property of their respective owners. The depiction, description or sale of products featuring these names, trademarks, brands and logos is for identification purposes only and is not intended to indicate any affiliation with or authorisation by any rights holder.

    Filter Results
    Results 551-600 of 590.
    NOVOTECHNIK TH1-0800-102-423-102

    NOVOTECHNIK

    TH1-0800-102-423-102

    LINEAR TRANSDUCER 4-20 MAH
    €933.17 Price with VAT: €1,110.48 Buy Surplus As Low As €559.90 Price with VAT: €666.29
    €559.90 Price with VAT: €666.29
    Repair Yours Contact Us
    NOVOTECHNIK LWI750R

    NOVOTECHNIK

    LWI750R

    LNR ACTUATOR
    €546.57 Price with VAT: €650.42 Buy Surplus As Low As €327.94 Price with VAT: €390.25
    €327.94 Price with VAT: €390.25
    Repair Yours Contact Us
    NOVOTECHNIK LWH-255

    NOVOTECHNIK

    LWH-255

    TRANSDUCER
    €255.07 Price with VAT: €303.53 Buy Surplus As Low As €152.86 Price with VAT: €181.91
    €152.86 Price with VAT: €181.91
    Repair Yours Contact Us
    NOVOTECHNIK LWH6003

    NOVOTECHNIK

    LWH6003

    POTENTIOMETER
    €546.57 Price with VAT: €650.42 Buy Surplus As Low As €327.94 Price with VAT: €390.25
    €327.94 Price with VAT: €390.25
    NOVOTECHNIK TR-75

    NOVOTECHNIK

    TR-75

    LINEAR TRANSDUCER 75MM
    €339.23 Price with VAT: €403.69 Buy Surplus As Low As €203.71 Price with VAT: €242.42
    €203.71 Price with VAT: €242.42
    Repair Yours Contact Us
    NOVOTECHNIK GP03P6501A50

    NOVOTECHNIK

    GP03P6501A50

    POTENTIOMETER
    €344.83 Price with VAT: €410.35 Buy Surplus As Low As €228.41 Price with VAT: €271.80
    €228.41 Price with VAT: €271.80
    NOVOTECHNIK RFC-4801-609-322-256

    NOVOTECHNIK

    RFC-4801-609-322-256

    RFC-4801-609-322-256
    €151.09 Price with VAT: €179.79 Buy Surplus As Low As €90.65 Price with VAT: €107.88
    €90.65 Price with VAT: €107.88
    NOVOTECHNIK RFC4851-636-122-501

    NOVOTECHNIK

    RFC4851-636-122-501

    ROTARY POTENTIOMETER
    €258.62 Price with VAT: €307.76 Buy Surplus As Low As €129.76 Price with VAT: €154.41
    €129.76 Price with VAT: €154.41
    NOVOTECHNIK RSC2802-212-411-432

    NOVOTECHNIK

    RSC2802-212-411-432

    SENSOR, HALL EFFECT, ROTARY DISPLACEMENT
    €407.92 Price with VAT: €485.42 Buy Surplus As Low As €203.96 Price with VAT: €242.71
    €203.96 Price with VAT: €242.71
    NOVOTECHNIK MAP4010-210-101

    NOVOTECHNIK

    MAP4010-210-101

    CONTROL INDICATOR, PROGRAMMABLE PROCESS
    €524.81 Price with VAT: €624.53 Buy Surplus As Low As €315.36 Price with VAT: €375.28
    €315.36 Price with VAT: €375.28
    Repair Yours Contact Us
    NOVOTECHNIK RSC2801-212-411-432

    NOVOTECHNIK

    RSC2801-212-411-432

    HALL EFFECT ROTARY DISPLACEMENT SENSOR
    €216.72 Price with VAT: €257.89 Buy Surplus As Low As €108.36 Price with VAT: €128.95
    €108.36 Price with VAT: €128.95
    NOVOTECHNIK RFC 4853 603 111 201

    NOVOTECHNIK

    RFC 4853 603 111 201

    ROTARY SENSOR, TOUCHLESS, 2-PART, MECHANICALLY DECOUPLED, IP67, IP6K9K
    €186.64 Price with VAT: €222.10 Buy Surplus As Low As €111.98 Price with VAT: €133.26
    €111.98 Price with VAT: €133.26
    NOVOTECHNIK TRS 75 A 502

    NOVOTECHNIK

    TRS 75 A 502

    POSITION TRANSDUCER, 55MM STROKE, 90 DEGREE CONNECTOR, EEM 33-72
    €429.26 Price with VAT: €510.82 Buy Surplus As Low As €257.73 Price with VAT: €306.70
    €257.73 Price with VAT: €306.70
    NOVOTECHNIK MAP-4010-001-101

    NOVOTECHNIK

    MAP-4010-001-101

    MEASURING DEVICE, MULTIFUNCTIONAL, WITH DISPLAY, MAP4000 SERIES
    €535.91 Price with VAT: €637.73 Buy Surplus As Low As €321.72 Price with VAT: €382.85
    €321.72 Price with VAT: €382.85
    NOVOTECHNIK 602078

    NOVOTECHNIK

    602078

    COUPLING FLANGE T-SERIES, FOR T/TS SERIES (MOUNTS TO SHAFT…602077 MOUNTS TO THIS),
    €52.44 Price with VAT: €62.40 Buy Surplus As Low As €31.99 Price with VAT: €38.07
    €31.99 Price with VAT: €38.07
    NOVOTECHNIK TS-0100 #023235

    NOVOTECHNIK

    TS-0100 #023235

    PNEUMATIC TRANSDUCER, POSITION, UP TO 100 MM
    €410.93 Price with VAT: €489.01 Buy Surplus As Low As €235.18 Price with VAT: €279.86
    €235.18 Price with VAT: €279.86
    NOVOTECHNIK SPF-3-1 W/ 6 MM BORE

    NOVOTECHNIK

    SPF-3-1 W/ 6 MM BORE

    004238-01, ROD END BEARING FOR LWH,
    €39.10 Price with VAT: €46.53 Buy Surplus As Low As €24.00 Price with VAT: €28.56
    €24.00 Price with VAT: €28.56
    NOVOTECHNIK SPF4-157

    NOVOTECHNIK

    SPF4-157

    004239-01, 6MM SHAFT ROTARY COUPLING,
    €12.44 Price with VAT: €14.81 Buy Surplus As Low As €7.47 Price with VAT: €8.88
    €7.47 Price with VAT: €8.88
    NOVOTECHNIK Z-103-G03

    NOVOTECHNIK

    Z-103-G03

    005687, 3MM SHAFT ROTARY COUPLING,
    €113.76 Price with VAT: €135.37 Buy Surplus As Low As €68.43 Price with VAT: €81.44
    €68.43 Price with VAT: €81.44
    NOVOTECHNIK Z-104-G06

    NOVOTECHNIK

    Z-104-G06

    005690, 6MM SHAFT ROTARY COUPLING,
    €120.87 Price with VAT: €143.83 Buy Surplus As Low As €72.88 Price with VAT: €86.72
    €72.88 Price with VAT: €86.72
    NOVOTECHNIK Z-105-G06

    NOVOTECHNIK

    Z-105-G06

    005691, 6MM SHAFT ROTARY COUPLING,
    €120.87 Price with VAT: €143.83 Buy Surplus As Low As €72.88 Price with VAT: €86.72
    €72.88 Price with VAT: €86.72
    NOVOTECHNIK Z-106-G-6

    NOVOTECHNIK

    Z-106-G-6

    103910, 6MM SHAFT ROTARY COUPLING,
    €102.20 Price with VAT: €121.62 Buy Surplus As Low As €61.32 Price with VAT: €72.97
    €61.32 Price with VAT: €72.97
    NOVOTECHNIK Z-301-M6/M6

    NOVOTECHNIK

    Z-301-M6/M6

    058001, FLEX SHAFT COUPLING FOR LWH - 6MM THREAD MATING THREAD,
    €71.10 Price with VAT: €84.61 Buy Surplus As Low As €42.66 Price with VAT: €50.76
    €42.66 Price with VAT: €50.76
    NOVOTECHNIK Z-G-03

    NOVOTECHNIK

    Z-G-03

    108551, PIVOT BEARINGS 2X/NUTS 2X (M8, SS) FOR LWG/LWX,
    €111.98 Price with VAT: €133.26 Buy Surplus As Low As €67.54 Price with VAT: €80.38
    €67.54 Price with VAT: €80.38
    NOVOTECHNIK Z-106-G-6.35

    NOVOTECHNIK

    Z-106-G-6.35

    103912, 1/4" SHAFT ROTARY COUPLING,
    €102.20 Price with VAT: €121.62 Buy Surplus As Low As €61.32 Price with VAT: €72.97
    €61.32 Price with VAT: €72.97
    NOVOTECHNIK Z-110-G10

    NOVOTECHNIK

    Z-110-G10

    005692, 10MM SHAFT ROTARY COUPLING,
    €176.86 Price with VAT: €210.46 Buy Surplus As Low As €106.65 Price with VAT: €126.91
    €106.65 Price with VAT: €126.91
    NOVOTECHNIK Z-301-M5/M5

    NOVOTECHNIK

    Z-301-M5/M5

    058002, FLEX SHAFT COUPLING 5MM MATING AND COUPLING THREADS,
    €71.10 Price with VAT: €84.61 Buy Surplus As Low As €42.66 Price with VAT: €50.76
    €42.66 Price with VAT: €50.76
    NOVOTECHNIK Z-301-M6/M4

    NOVOTECHNIK

    Z-301-M6/M4

    005679, FLEX SHAFT COUPLING FOR LWH - 4MM THREAD MATING THREAD,
    €139.53 Price with VAT: €166.04 Buy Surplus As Low As €84.43 Price with VAT: €100.47
    €84.43 Price with VAT: €100.47
    2 3 4 5 6 7 8 9 10 11 12